Com resoldre l’error del plugin qTranslate

By 23 abril, 2014 noviembre 15th, 2014 No Comments

Què passa quan WordPress s’actualitza i utilitzem el plugin qTransalte? Doncs que aquest deixa de funcionar =)  I perquè ho fa? Doncs perquè sigui fàcil d’entendre i sense entrar en detalls heu de suposar que qTranslate es desenvolupa per a una versió de WordPress, per exemple la 3.8.1. Doncs qTranslate enten que allò funcionarà per a aquesta versió correctament i ha estat auditada per aquesta versió en concret i abans d’executar te una funció que pregunta:

qTranslate que ha estat preperada per a la versió 3.8.1 s’està executant en la mateixa versió de WordPress?

Si la versió de WordPress és diferent a 3.8.1 doncs ens llença un missatge que diu: “Oju! Que això no ho hem provat i potser la liem!”.

Una manera ràpida de resoldre això és la de forçar la versió per a la que ha estat preperat qTranslate i modificant el valor per la versió instal·lada de WordPress.

 

define('QT_SUPPORTED_WP_VERSION', '3.4.2');

El segon valor ‘3.4.2’ ens ha de coïncidir amb la versió de WordPress que podem trobar a dalt a l’esquerra del dashboard fent clic a sobre d’About  WordPress.

Met El Idrissi

Met El Idrissi

Desarrollador web WordPress freelance y emprendedor tecnológico en aplicaciones web SaaS

Leave a Reply